Friday, 4 July 2008

Cisco VPN Software Breaks When Upgrading to Leopard


I recently upgraded my MacBook to OS X 10.5 ("Leopard"). By and large it's been a pretty painless experience except for the fact that the work issued Cisco VPN client often starts up with an error. The error says, in part "Unable to communicate with the VPN subsystem."

Googling around the suggested fix is to restart the Cisco kernel extension. The following terminal command takes care of things nicely:
$ sudo /System/Library/StartupItems/CiscoVPN/CiscoVPN restart
I'm running version 4.9.01 by the way.

What the hell, here's a video of it if the command line is not where your heart truly lies.

No comments: